gogoNET

IPv6 & Networking the Internet of Things

I am looking to get a /56 how do I go about this?

Thanks,

-Derek DiGiacomo

Views: 424

Reply to This

Replies to This Discussion

You can be allocated a /56 but you need to connect as an authenticated user. Sign up an account here:http://gogonet.gogo6.com/page/freenet6-registration

 

you then need to tell the client that it's a router and you'll get a /56

did that and got my confirmation email that I am registered but not sure where to go to request the /56?  I havent downloaded the client yet, is that a prerequisite?

"I havent downloaded the client yet, is that a prerequisite?"

 

Yep.  Also, that /56 will in fact be 256 /64s.  On IPv6, the subnet on the local lan is normally a /64.  The 48 bit MAC address gets padded out to 64 bits by placing FFFE in the middle of it.  This 64 bit number added to your subnet address becomes your global IPv6 address.

 

Yep, you need to do it inside the client.

Silly question...  Is there an easy way to find out the assigned /56 prefix other than turning on console logging in gw6c?  It works but it seems kind of ugly.

 

Cheers,

Dave

Well, the ifconfig command in Linux or ipconfig in Windows should show what address you get, which includes the subnet.  It will be the first /64 subnet, which has the same first address as your /56.

 

If I do an ifgonfig, I get:

 

tun       Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00 
          inet6 addr: 2001:5c0:1000:b::8e65/128 Scope:Global
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1280  Metric:1
          RX packets:7 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:500
          RX bytes:472 (472.0 b)  TX bytes:56 (56.0 b)

 

which is just the tunnel IPv6 address created with gogoc.  I tried running gw6c without running gogoc and it appears to require having the host-to-host tunnel in place.  I run gw6c after getting the host tunnel up and it runs to completion but does not appear to change anything.  I set console logging to level 3 and I get (along with a bunch of other, fairly uninteresting stuff):

 

RUDP packet 0, RTO 2.512928, sequence 0xf00000f4 timestamp 1321.
Reply: RUDP packet 0, RTO 2.512928, sequence 0xf00000f4 timestamp 1321.
Received: '200 Success
<tunnel action="info" type="v6udpv4" lifetime="604800">
  <server>
    <address type="ipv4">64.86.88.116</address>
    <address type="ipv6">2001:05c0:1000:000b:0000:0000:0000:8f60</address>
  </server>
  <client>
    <address type="ipv4">68.170.57.104</address>
    <address type="ipv6">2001:05c0:1000:000b:0000:0000:0000:8f61</address>
    <address type="dn">dandjrouter.broker.freenet6.net</address>
    <router>
      <prefix length="56">2001:05c0:110c:c100:0000:0000:0000:0000</prefix>
    </router>
    <keepalive interval="30">
      <address type="ipv6">2001:05c0:1000:000b:0000:0000:0000:8f60</address>
    </keepalive>
  </client>
</tunnel>

 

This appears to indicate that I'm getting a /56 address block but I don't see the IPv6 addresses listed above showing up anywhere.

 

I'm new at IPv6 and learning as I'm going so it's possible that I'm missing a step or got something wrong.  Thanks for any help or suggestions.

 

Cheers,

Dave

What does your ethernet interface show?  On my Linux firewall, the interface connected to the local lan shows an IPv6 address on my subnet.  The IPv6 address you show above is your end of the tunnel and not an address in your subnet.

 

 

That's the problem.  ifconfig for eth1 looks like:

 

eth1      Link encap:Ethernet  HWaddr 00:0C:29:41:D2:3C 
          inet addr:172.16.3.1  Bcast:172.16.3.255  Mask:255.255.255.0
          inet6 addr: 2001:5c0:110c:c100::1/64 Scope:Global
          inet6 addr: fe80::20c:29ff:fe41:d23c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:328282 errors:0 dropped:0 overruns:0 frame:0
          TX packets:531826 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:24862836 (23.7 MiB)  TX bytes:764270307 (728.8 MiB)
          Interrupt:67 Base address:0x2080


but that's due to me setting it in ifcfg-eth1:

 

[root@centos-5x-1 bin]# cat /etc/sysconfig/network-scripts/ifcfg-eth1
# Advanced Micro Devices [AMD] 79c970 [PCnet32 LANCE]
DEVICE=eth1
BOOTPROTO=none
ONBOOT=yes
HWADDR=00:0c:29:41:d2:3c
NETMASK=255.255.255.0
IPADDR=172.16.3.1
IPV6ADDR=2001:05c0:110c:c100:0000:0000:0000:0001
IPV6_ROUTER=yes
GATEWAY=192.168.0.6
TYPE=Ethernet
USERCTL=no
IPV6INIT=yes
PEERDNS=yes

 

gw6c.conf has if_prefix set to eth1.  gogoc was automatic as far as making the connections, I was sort of expecting the same sort of behavior for gw6c.  Plus, I'm not getting IPv6 connectivity for systems that were on the 172.16.3.0 IPv4 subnet.  These systems are getting addresses on the /56 net but "can't get out."

 

Cheers,

Dave

Do you have radvd running?

 

You don't mention what linux distro you're running, but when I set up my OpenSUSE firewall, I had to modify the config script to get radvd to work.

 

The box serving as router is running CentOS 5 with all current updates applied (still waiting on 5.6 :D).  radvd is running.  The config file looks like:

 

#
interface eth1
{
        AdvSendAdvert on;
        MinRtrAdvInterval 30;
        MaxRtrAdvInterval 100;

        prefix 2001:05c0:110c:c100:0000:0000:0000:0000/64
        {
                AdvOnLink on;
                AdvAutonomous on;
                AdvRouterAddr on;
        };

};

 

The clients (one ubuntu box and another CentOS box) are picking up the advertised address automatically.  The problem seems to be that route shows the address of the "client" (from the gw6c output, above).  It's almost like I need the equivalent of an IPv4 "route add" to add the route to eth1 but I thought radvd was supposed to take care of that.

 

Cheers,

Dave

Second reply.  After exhausting everything I could think of, I rebooted the server/router to get back to a clean slate.  I restarted gogoc and gw6c and everything just worked.  The client boxes now test ipv6 clean at test-ipv6.com and the server/router still does.

 

I'm guessing that I built up enough cruft while flailing that I just needed a clean start.  I've got a couple of edits to the ifcfg file on the CentOS client that I want to back out but otherwise everything seems to be good.

 

I appreciate your time even if the solution was on my end to just start over clean.  Thanks.  I try to stay philosophical about this sort of exercise.  I don't learn nearly as much when something just works.  When I have to scratch my head and double check that everything is set up correctly, I learn a lot.

 

Cheers,

Dave

RSS

Training

IoT & IPv6 Networking Conference

Product Information

Fill out my online form.

© 2014   Created by gogo6.

Badges  |  Report an Issue  |  Terms of Service