gogoNET

IPv6 products, community and services

Coming soon.

Views: 3876

Reply to This

Replies to This Discussion

OpenWRT Client
Product description
The Client has been ported to the OpenWRT Whiterussian RC6 platform.

You can now use the Linksys WRT54G(S) line of home gateways to get IPv6 connection through the Freenet6 service or any other gogoSERVER TSP tunnel service.

Get the READ ME to help you through the upgrade process.

Click here or the download link above to get the packages needed for the upgrade.

1 download the image and unzip it
2 log in to your dd-wrt router
3 run the upgrade link and point to the above image
4 white russian version is installed and under networking is the ipv6 tunnel set up

so far the main bugs are that the config is over written.

ssh in to the router, copy /var/run/gw6c/gw6c.conf /etc
edit /etc/gw6.conf...change prefix to 64, change user / password and ensure router is your option.
save conf file and manually run

gw6c -f /etc/gw6c.conf

This got the tunnel up and running for me, I could ping6 and ssh in both directions on ipv6 addresses

connecting a win xp client to the lan side (ethernet) assigned a dhcp ipv6 address and allowed me to view ipv6.google.com and ping -6 addresses.

hope this helps and that I got the file names right off the top of my head
Thanks!!!
I followed the link above to download the packages and binaries, but all the files have the same filename and 2007 stamp that was on go6.net before.
Please let me know if anything has changed in the OpenWRT port.
I intend to install this on an WRT54GL, wonder if anyone tried it there ? If so, which version of DD-WRT was used (Mega, VoIP, Standard, etc.) ? I intend to do an ipkg install to retain the slick DD-WRT interface.
Need help on the following: I want to get the *proper* version of gogoCLIENT on OpenWRT using a Linksys router, and found the binaries on http://www.go6.net/4105/download.asp

Do we know if it will work on the WRT54GL (which according to Cisco is "Wireless-G Linux Broadband Router created specially for hobbyists and wireless aficionados") ? I checked http://nuwiki.openwrt.org/oldwiki/hardware/linksys and WRT54GL has identical specs to WRT54GS-v4 and the latter already has a binary for on go6.net

Please confirm if this is the binary to use. I want to avoid going down the path of flashing with a new binary, then finding it doesn't work and the original router status cannot be restored ... thx.
What you find on the client download page aren't images for openwrt but only packages to be installed on an existing system. The package was built for the previous version of openwrt but people have managed to get it to work on the latest versions as well. To flash your device you have to go to http://openwrt.org/ and get the correct image.
I am confused:
The OpenWRT Readme on go6.net that James refers to states, "Hexago provides prebuilt, full firmware images containing the Gateway6 Client application and all required dependencies, or alternatively, packages with the Gateway6 Client application and the modified web interface".
The firmware images (*.bin) on the go6.net site, that James refers to, are easier to install. Indeed the full firmware installation is explained in Option 1 in the Readme for installation.
So why do I have to install packages and ignore the full firmware option ?
Sorry, I din't think of those since they are old versions of openwrt, whiterussian. Don't know what platforms are supported, check with openwrt which have more information on what release works with which platform. It seems to depend on which revision number of a model you have so you need to make sure.

The gw6c package for the last openwrt release (backfire) is in the backfire repository itself, so just update you package list (opkg update) and then download it (opkg install gw6c). But the are still several issues:

  1. the syntax of the config file is totally wrong: you have to manually convert every parameter setting line, using "param=value" instead of "option param value". gw6c will refuse to start complaining for missing assignements.
  2. the logging facility is disabled by default: enable it and look for the file into /var/log
  3. the client will look for "openwrt.sh" template in the wrong directory, despite that in the config file the gw6c directory is properly defined; the workaround is to look at the log file, to discover where the client expects the template, and then "ln -s" to it
  4. even when every looks ok, the client starts but, after correctly setting up the tunnel, it terminates without further diagnostics (I still have to work on this)
I will post my config file and a further note when I'll have worked out this.
Great, it will be good to get the corrected config file once its all worked out, and please let us know which device this was tested on.
Sorry: Linksys WRT54G3G
I installed gw6c on the latest OpenWRT release (through 'opkg gw6c', on a Linksys WRT54GL) and configured the settings according to openwrt TSP instruction.

When starting the gw6c all seems to go well, but I don't see anything actually happened. No new process is running, no new tunnel interface is added (I assume this should be occurring).

root@OpenWrt:~# /etc/init.d/gw6c start
Starting Gateway6 client.
Gateway6 Client v5.1-RELEASE build Jul 12 2011-10:05:06 
Built on ///Linux nd-build-02.linux-appliance.net 2.6.18-238.12.1.el5PAE #1 SMP Tue May 31 14:02:45 EDT 2011 i686 i686 i386 GNU/Linux///
Connection to amsterdam.freenet6.net established.
root@OpenWrt:~#

root@OpenWrt:~# ps aux | grep gw6c
 6462 root      1356 S    grep gw6c
root@OpenWrt:~#

root@OpenWrt:~# ping6 ipv6.google.com
PING ipv6.google.com (2a00:1450:8005::93): 56 data bytes
ping6: sendto: Network is unreachable
root@OpenWrt:~#

Does anybody have any clue what could be the problem here? Is this the same issue that Niccolo points out above at his point 4?

Thanks,
Casper

RSS

Sponsor

special report

Training

gogoTRAINING

IPv6 Product Information

Fill out my online form.

© 2014   Created by gogo6.

Badges  |  Report an Issue  |  Terms of Service