gogoNET

IPv6 & Networking the Internet of Things

Not starting gogoc - no server key [fail]
hmm, lets see

check_server_key() looks for a 3des key,
maybe I should find some packages for that
nope, not helping

start anonymous
nope, not helping

use digest-md5 instead of passdss-3des-1
hey it works

Views: 4279

Reply to This

Replies to This Discussion

Yes,replace the auth_method with that ,it can start ,but exec "ifconfig",there isn't a interface named "tun-00" like that ,so that won't work ?

Hello!I don't know if you already solved your problem however this is the solution: to retrive the server key just run this command fron the command line

 

sudo /usr/sbin/gogoc -n

 

and answer Y gogoc asks you to add the server key.

 

When you have the server key just press Ctrl + C to stop gogoc and restart is as a system service with the command

 

sudo service gogoc start

 

ATTENTION: please note the "-n" switch passed to gogoc when calling the gogoc binarydirectly to retrive the server key, this switch tells gogoc to start in foregroung instead of in daemon mode. If you don't use the "-n" gogoc start as a daemon and do not ask you anything about adding server key, it simply (and silently) fails to connect to the server ....also note that in Debian 6.0 squeeze documentation abut gogoc they explain how to retrive the server key BUT they forget to tell you about the "-n" switch so those instructions does not works! A user already reported this error to Debian developers.

OK, still problems due tue load balancing ....gogoc uses the server authenticated.freenet6.net to create the tunnel but this is not a real server, it is only a name used for load balancing, looking at gogoc logs I found that my real server is montreal.freenet6.net and I have the key for this server (retrived using the method in my previous post) ....now the problem is that the server key is stored with the name montreal.freenet6.ney but in gogoc configuration file the server name is authenticated.freenet6.net ....and there is no key for this server ....because this is not a real server!!!!

 

WORKING SOLUTION: disable the server key checking for gogoc in /etc/default/gogoc

 

UNTESTED SOLUTION: change server name from authenticated.freenet6.net to montreal.freenet6.net (or another of their server) ad get the key for that server ....remember that this way load balancing is disabled

Restore your configuration file to the default values. (authenticated.freenet6.net is ok)

From terminal CLI.

cd /var/lib/gogoc   (do cd or nothing will work as gogoc doesn't know where to put the generated files!)

edit

tsp-broker-list.txt

add

montreal.freenet6.net
amsterdam.freenet6.net
taipei.freenet6.net
sydney.freenet6.net

save file

run

/usr/sbin/gogoc -n -f/etc/gogoc/gogoc.conf

answer y to any request.

In this way the file var/lib/gogoc/gogockeys.pub will be created and then recognized.

Restart gogoc through init

Remind that only if you use always the same broker server, you will be assigned the same IP address pool!!!

 

Спасибо! все получилось!

my situation is on the contrary to yours.I only use passdss-3des-1 instead of others that it can work.so people should try every authentication to make it ok!

RSS

Training

IoT & IPv6 Networking Conference

Product Information

Fill out my online form.

© 2014   Created by gogo6.

Badges  |  Report an Issue  |  Terms of Service